Go Back   Micro PC Talk Forums > Micro PC > Alternate OS > Linux OS

Reply
Thread Tools Display Modes
  #1  
Unread 11-11-2010, 08:29 AM
verysmall Offline
Junior Member
 
Join Date: Nov 2010
Posts: 6
Cool Howto Ubuntu10.04 + Sound
well, excuse me for my english(,i always want to meet a friend who speak english to help me , let's get to the point.

my device is ux17gp(possably a chinese name) with ubuntu 10.04, they told me add some code to "alsa-base.conf" or setup "mono" control, bala bala bala, but it does not work for me, the 10.04 donot have a mono control!!!!!!

so i tried tried and tried, at least i uninstall pulseaudio & alsa, try OSS
(download in: http://www.opensound.com/download.cgi)
select "x86 deb"
and "sudo dpkg -i oss-linux*.deb"
and "osstest"
ok, now u can hear something.

i wash this can help u, and make some friends
Reply With Quote
  #2  
Unread 11-11-2010, 01:43 PM
bigs Offline
Senior Member
 
Join Date: Jul 2010
Posts: 1,498
Awards Showcase
500 Posts 100 Posts 
Total Awards: 2
Default
hi, do this

Open a terminal and type:
sudo gedit /etc/modprobe.d/alsa-base.conf

Add this line to the bottom of the file:
options snd-hda-intel model=auto

Save and close the file. Reboot.

acknowledgement goes to http://liliputer.blogspot.com/2010/0...x-on-sony.html

Guaranteed fix as long as you have not damaged ubuntu too much with your mods to get sound going.

bigs
__________________
micropc hardware: sony ux17gp with 390N mainboard with Anh u7700 upgrade core2duo 1.33ghz 1024mb (now upgraded to 64gb SLC SSD Samsung), Intel 4965 agn wireless, upgrade addon 3rd mini aerial, UX37GBN blue housing incorporating improved keyboard
OS: Linux Ubuntu 10.04 lucid & now 12.04 Precise Pangolin!
sony 380N stock 1.33ghz, 1gb ram, and 40gb rotational drive OS: windows ultimate
light slim notebook: toshiba r200 1.3ghz 1.2gb ram 64gb photofast v1 ssd oS: linux ubuntu 7.04 feisty fawn
Reply With Quote
  #3  
Unread 11-11-2010, 10:00 PM
kiz Offline
Senior Member
 
Join Date: Jul 2007
Posts: 172
Awards Showcase
100 Posts 
Total Awards: 1
Default
is this for the desktop edition or netbook editiion
Reply With Quote
  #4  
Unread 11-12-2010, 08:40 AM
verysmall Offline
Junior Member
 
Join Date: Nov 2010
Posts: 6
Default
yes, i tried to add that line to alsa-base.conf, but it is not work for me, i donot know why
and i install pulseaudio(because i cannot get a volume control...) whthout uninstall oss, it is still working, so i think you just install or update oss will be ok.

i am using ubuntu 10.04 for desktop

someone can help my mouse wheel ? the middle mouse button is not work (,everything else is now perfact except this)!
Reply With Quote
  #5  
Unread 11-12-2010, 09:11 AM
bigs Offline
Senior Member
 
Join Date: Jul 2010
Posts: 1,498
Awards Showcase
500 Posts 100 Posts 
Total Awards: 2
Default
hmm verysmall, thats strange, my ubuntu 10.04 desktopworks a treat with that mod. Mabe do a fresh install of ubuntu and try again? All ux to my knowledge use the same sound hardware so it should work. To test, install XP and install xp sound driver. If sound does not work, then your ux may need a new sound board.

bigs
__________________
micropc hardware: sony ux17gp with 390N mainboard with Anh u7700 upgrade core2duo 1.33ghz 1024mb (now upgraded to 64gb SLC SSD Samsung), Intel 4965 agn wireless, upgrade addon 3rd mini aerial, UX37GBN blue housing incorporating improved keyboard
OS: Linux Ubuntu 10.04 lucid & now 12.04 Precise Pangolin!
sony 380N stock 1.33ghz, 1gb ram, and 40gb rotational drive OS: windows ultimate
light slim notebook: toshiba r200 1.3ghz 1.2gb ram 64gb photofast v1 ssd oS: linux ubuntu 7.04 feisty fawn
Reply With Quote
  #6  
Unread 06-05-2011, 10:13 PM
UXmd Offline
Junior Member
 
Join Date: Jun 2009
Posts: 11
Default
Verysmall, one of my buddies was having the same issue, when I checked what he was doing wrong, he was not putting a space after 'gedit' and before the / . Bigs, that is a great mod from liliputer's webpage. Have you guys done any power management mods for 10.04?
Reply With Quote
  #7  
Unread 06-05-2011, 10:39 PM
bigs Offline
Senior Member
 
Join Date: Jul 2010
Posts: 1,498
Awards Showcase
500 Posts 100 Posts 
Total Awards: 2
Default
"You need to modify the /etc/modprobe.d/alsa-base file
Open a terminal and type:
sudo gedit /etc/modprobe.d/alsa-base.conf


Add this line to the bottom of the file:
options snd-hda-intel model=auto

Save and close the file. Reboot.

If not already installed, install alsamixer.
sudo apt-get install gnome-alsamixer"

from lilkputer page just in case the page changes one day.


Also for power management on vaio, check out http://vaio-utils.org/

it is frequently updated and has very good and flecible power options for ubuntu on vaios which work on the ux.
__________________
micropc hardware: sony ux17gp with 390N mainboard with Anh u7700 upgrade core2duo 1.33ghz 1024mb (now upgraded to 64gb SLC SSD Samsung), Intel 4965 agn wireless, upgrade addon 3rd mini aerial, UX37GBN blue housing incorporating improved keyboard
OS: Linux Ubuntu 10.04 lucid & now 12.04 Precise Pangolin!
sony 380N stock 1.33ghz, 1gb ram, and 40gb rotational drive OS: windows ultimate
light slim notebook: toshiba r200 1.3ghz 1.2gb ram 64gb photofast v1 ssd oS: linux ubuntu 7.04 feisty fawn
Reply With Quote
  #8  
Unread 05-02-2012, 05:22 PM
machineman Offline
Junior Member
 
Join Date: Oct 2011
Posts: 1
Thumbs up how to Ubuntu10.04+
I just installed Ubuntu 12.04 LTS on a 4gb usb flash drive. I attempted this tweak and it work immediately. Thanx a million. I am learning so much from you guys.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT. The time now is 01:45 PM.
Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.