Howto Ubuntu10.04 + Sound

verysmall
Junior Member
Posts: 6
Joined: Wed Nov 10, 2010 15:40

Howto Ubuntu10.04 + Sound

Postby verysmall » Thu Nov 11, 2010 09:29

well, excuse me for my english(,i always want to meet a friend who speak english to help me :), let's get to the point.

my device is ux17gp(possably a chinese name) with ubuntu 10.04, they told me add some code to "alsa-base.conf" or setup "mono" control, bala bala bala, but it does not work for me, the 10.04 donot have a mono control!!!!!!

so i tried tried and tried, at least i uninstall pulseaudio & alsa, try OSS
(download in: http://www.opensound.com/download.cgi)
select "x86 deb"
and "sudo dpkg -i oss-linux*.deb"
and "osstest"
ok, now u can hear something.

i wash this can help u, and make some friends:D

bigs
Senior Member
Posts: 1601
Joined: Thu Jul 29, 2010 21:07

Postby bigs » Thu Nov 11, 2010 14:43

hi, do this

Open a terminal and type:
sudo gedit /etc/modprobe.d/alsa-base.conf

Add this line to the bottom of the file:
options snd-hda-intel model=auto

Save and close the file. Reboot.

acknowledgement goes to http://liliputer.blogspot.com/2010/04/testing-ubuntu-1004-lucid-lynx-on-sony.html

Guaranteed fix as long as you have not damaged ubuntu too much with your mods to get sound going.

bigs
micropc hardware: sony ux17gp with 390N mainboard with Anh u7700 upgrade core2duo 1.33ghz 1024mb (now upgraded to 64gb SLC SSD Samsung), Intel 4965 agn wireless, upgrade addon 3rd mini aerial, UX37GBN blue housing incorporating improved keyboard
OS: Linux Ubuntu 10.04 lucid & now 12.04 Precise Pangolin!
sony 380N stock 1.33ghz, 1gb ram, and 40gb rotational drive OS: windows ultimate
light slim notebook: toshiba r200 1.3ghz 1.2gb ram 64gb photofast v1 ssd oS: linux ubuntu 7.04 feisty fawn

kiz
Senior Member
Posts: 173
Joined: Thu Jul 26, 2007 22:24

Postby kiz » Thu Nov 11, 2010 23:00

is this for the desktop edition or netbook editiion

verysmall
Junior Member
Posts: 6
Joined: Wed Nov 10, 2010 15:40

Postby verysmall » Fri Nov 12, 2010 09:40

yes, i tried to add that line to alsa-base.conf, but it is not work for me, i donot know why
and i install pulseaudio(because i cannot get a volume control...) whthout uninstall oss, it is still working, so i think you just install or update oss will be ok.

i am using ubuntu 10.04 for desktop

someone can help my mouse wheel ? the middle mouse button is not work (,everything else is now perfact except this)!

bigs
Senior Member
Posts: 1601
Joined: Thu Jul 29, 2010 21:07

Postby bigs » Fri Nov 12, 2010 10:11

hmm verysmall, thats strange, my ubuntu 10.04 desktopworks a treat with that mod. Mabe do a fresh install of ubuntu and try again? All ux to my knowledge use the same sound hardware so it should work. To test, install XP and install xp sound driver. If sound does not work, then your ux may need a new sound board.

bigs
micropc hardware: sony ux17gp with 390N mainboard with Anh u7700 upgrade core2duo 1.33ghz 1024mb (now upgraded to 64gb SLC SSD Samsung), Intel 4965 agn wireless, upgrade addon 3rd mini aerial, UX37GBN blue housing incorporating improved keyboard

OS: Linux Ubuntu 10.04 lucid & now 12.04 Precise Pangolin!

sony 380N stock 1.33ghz, 1gb ram, and 40gb rotational drive OS: windows ultimate

light slim notebook: toshiba r200 1.3ghz 1.2gb ram 64gb photofast v1 ssd oS: linux ubuntu 7.04 feisty fawn

UXmd
Member
Posts: 11
Joined: Mon Jun 15, 2009 08:28

Postby UXmd » Sun Jun 05, 2011 23:13

Verysmall, one of my buddies was having the same issue, when I checked what he was doing wrong, he was not putting a space after 'gedit' and before the / . Bigs, that is a great mod from liliputer's webpage. Have you guys done any power management mods for 10.04?

bigs
Senior Member
Posts: 1601
Joined: Thu Jul 29, 2010 21:07

Postby bigs » Sun Jun 05, 2011 23:39

"You need to modify the /etc/modprobe.d/alsa-base file
Open a terminal and type:
sudo gedit /etc/modprobe.d/alsa-base.conf


Add this line to the bottom of the file:
options snd-hda-intel model=auto

Save and close the file. Reboot.

If not already installed, install alsamixer.
sudo apt-get install gnome-alsamixer"

from lilkputer page just in case the page changes one day.


Also for power management on vaio, check out http://vaio-utils.org/

it is frequently updated and has very good and flecible power options for ubuntu on vaios which work on the ux. ;)
micropc hardware: sony ux17gp with 390N mainboard with Anh u7700 upgrade core2duo 1.33ghz 1024mb (now upgraded to 64gb SLC SSD Samsung), Intel 4965 agn wireless, upgrade addon 3rd mini aerial, UX37GBN blue housing incorporating improved keyboard

OS: Linux Ubuntu 10.04 lucid & now 12.04 Precise Pangolin!

sony 380N stock 1.33ghz, 1gb ram, and 40gb rotational drive OS: windows ultimate

light slim notebook: toshiba r200 1.3ghz 1.2gb ram 64gb photofast v1 ssd oS: linux ubuntu 7.04 feisty fawn

machineman
Junior Member
Posts: 1
Joined: Mon Oct 10, 2011 03:04

how to Ubuntu10.04+

Postby machineman » Wed May 02, 2012 18:22

:D I just installed Ubuntu 12.04 LTS on a 4gb usb flash drive. I attempted this tweak and it work immediately. Thanx a million. I am learning so much from you guys.


Return to “Linux OS”

Who is online

Users browsing this forum: No registered users and 2 guests